Stabilitrak

Shocks, springs, airbags, hydraulics...

Moderators: SS-ROB, Got TBSS, 08bluedemon

User avatar
Gzero
Site Admin
Site Admin
Posts: 939
Joined: Thu Jun 11, 2015 10:09 am
Location: NW Arkansas
Contact:

Re: Stabilitrak

Post by Gzero » Fri Nov 20, 2015 8:30 am

Definitely need to get an alignment after lowering. Did you use the modified upper control arms?
07 3SS AWD Summit White - TVS1900|The Force Cam|HP Tuner Pro|RPM lvl6|Vig 3200 Tri-disk|Kooks 1-7/8" w/ ORY|Magnaflow Catback|4" MAF Fenderwell Intake|Dual LS1 eFans|PCM Pickup Tube|160* Stat|BM Trans Cooler|Dual Aeroforce|Anzo Halos & OPT7 HIDs|Big 3 Gnd|Pioneer 7" Nav|Massive Audio Subs & Amps|Diamond Audio Components

User avatar
08bluedemon
Moderator
Moderator
Posts: 565
Joined: Thu Jul 02, 2015 7:14 am
Location: Illinois

Post by 08bluedemon » Fri Nov 20, 2015 9:02 am

Trailblazer SS Lowering Struts
NC-DJMUPPER... NORCAL Modified Trailblazer Upper A -Arms Without Lowering Mounts
Labor Installation- Front struts, DJM A-arms and factory airbag lowering

This is what was done last year
"I had brain surgery what's your excuse "

User avatar
Gzero
Site Admin
Site Admin
Posts: 939
Joined: Thu Jun 11, 2015 10:09 am
Location: NW Arkansas
Contact:

Post by Gzero » Fri Nov 20, 2015 9:54 am

I have the same exact setup on the front. I didn't get my alignment done right away because life happens... By the time I took it in to have the alignment done, the tires were wearing a little weird, so I just had the front two tires replaced at the time of alignment. Tires have been wearing fine since. Before I had the alignment done, the truck drove fine and didn't pull, so you can't go off of that to tell if your alignment is off.
07 3SS AWD Summit White - TVS1900|The Force Cam|HP Tuner Pro|RPM lvl6|Vig 3200 Tri-disk|Kooks 1-7/8" w/ ORY|Magnaflow Catback|4" MAF Fenderwell Intake|Dual LS1 eFans|PCM Pickup Tube|160* Stat|BM Trans Cooler|Dual Aeroforce|Anzo Halos & OPT7 HIDs|Big 3 Gnd|Pioneer 7" Nav|Massive Audio Subs & Amps|Diamond Audio Components

User avatar
08bluedemon
Moderator
Moderator
Posts: 565
Joined: Thu Jul 02, 2015 7:14 am
Location: Illinois

Post by 08bluedemon » Fri Nov 20, 2015 12:10 pm

looks like I will be stopping on the way home to get it done. Thanks Bobby
"I had brain surgery what's your excuse "

User avatar
Gzero
Site Admin
Site Admin
Posts: 939
Joined: Thu Jun 11, 2015 10:09 am
Location: NW Arkansas
Contact:

Post by Gzero » Fri Nov 20, 2015 12:25 pm

Hope it works for you! Let us know how it goes!
07 3SS AWD Summit White - TVS1900|The Force Cam|HP Tuner Pro|RPM lvl6|Vig 3200 Tri-disk|Kooks 1-7/8" w/ ORY|Magnaflow Catback|4" MAF Fenderwell Intake|Dual LS1 eFans|PCM Pickup Tube|160* Stat|BM Trans Cooler|Dual Aeroforce|Anzo Halos & OPT7 HIDs|Big 3 Gnd|Pioneer 7" Nav|Massive Audio Subs & Amps|Diamond Audio Components

User avatar
08bluedemon
Moderator
Moderator
Posts: 565
Joined: Thu Jul 02, 2015 7:14 am
Location: Illinois

Post by 08bluedemon » Thu Dec 03, 2015 10:01 am

So finally have it all resolved with stabilitrak
Started with need well potion sensors then dig in a little more and had to replace both side wheel hube and bearings. Next was lower ball joints had to be replaced. Finally get a front end alignment.
Lastly had to get 2 new front tires. Benefit with that wasaid now I can get yokos back on the front.
Earlier this year when the in-laws used the truck they got 2 flats in the front and put Bridgestone on. With the bad alignment they didn't last long.
All said and done think total was about 1000. Not bad I guess
"I had brain surgery what's your excuse "

tino2know
LS
LS
Posts: 1
Joined: Thu Apr 18, 2019 5:34 am

Post by tino2know » Thu Apr 18, 2019 5:34 am

08bluedemon wrote:So finally have it all resolved with stabilitrak
Started with need well potion sensors then dig in a little more and had to replace both side wheel hube and bearings. Next was lower ball joints had to be replaced. Finally get a front end alignment.
Lastly had to get 2 new front tires. Benefit with that wasaid now I can get yokos back on the front.
Earlier this year when the in-laws used the truck they got 2 flats in the front and put Bridgestone on. With the bad alignment they didn't last long.
All said and done think total was about 1000. Not bad I guess
I’m having this issue now.


Sent from my iPhone using Tapatalk

Post Reply