Help please, cel codes n low power mode..

Having issues with your TBSS? Find help here by posting your problems and/or trouble codes.

Moderators: SS-ROB, Got TBSS, 08bluedemon

Post Reply
BoostedTBSS
LS
LS
Posts: 4
Joined: Wed Jun 06, 2018 1:24 am

Help please, cel codes n low power mode..

Post by BoostedTBSS » Tue Jun 26, 2018 1:49 pm

2006 AWD SS3

Please let me know if any of these issues would cause my trans to feel as if it was kinda lagging to shift 1st to 2nd.


I drive in the morning to work and was fine for a while, then was rear ended last Saturday and now the truck will just have a check engine light in the morning when leaving for work but no Low Power Mode, but feels like 1 to 2nd takes a little to engage. Then when it’s later in the day im driving home from work and CEL & low power mode lights are on and oil pressure drops to around 28-30 couple times lower...Also, I bought a brand new pedal assembly with the sensor on it and code stayed on so these are the codes I’m getting:

P0171 - System too lean, bank 1 (Prob that exhaust leak I have on driver side exhaust Mani to pipe but I have gasket to replace it)


P300 - Random/multiple cylinder(s) -misfire detected (Chevy says : Spark plug(s), HT lead(s), injector(s), ignition coil(s), low compression, wiring)

P2128 -Accelerator pedal position (APP) / Throttle position (TP) sensor/switch E - high input (Chevy says Wiring short to positive, APP / TP sensor/switch)

P2138 - Throttle position (TP) sensor/switch D/E - voltage correlation(Chevy said Wiring, TP sensor/switch)

Anyone with any info would be appreciated


Sent from my iPhone using Tapatalk

Post Reply